Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Qemu helper scripts" |
| 2 | LICENSE = "GPLv2" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 3 | RDEPENDS_${PN} = "nativesdk-qemu \ |
| 4 | nativesdk-python3-shell nativesdk-python3-fcntl nativesdk-python3-logging \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | " |
| 6 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | PR = "r9" |
| 8 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999 \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 10 | file://${COREBASE}/scripts/runqemu;endline=19;md5=a8ad1905c709a2deaa057608ebaf705a" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | |
| 13 | SRC_URI = "file://${COREBASE}/scripts/runqemu \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | file://${COREBASE}/scripts/runqemu-addptable2image \ |
| 15 | file://${COREBASE}/scripts/runqemu-gen-tapdevs \ |
| 16 | file://${COREBASE}/scripts/runqemu-ifup \ |
| 17 | file://${COREBASE}/scripts/runqemu-ifdown \ |
| 18 | file://${COREBASE}/scripts/oe-find-native-sysroot \ |
| 19 | file://${COREBASE}/scripts/runqemu-extract-sdk \ |
| 20 | file://${COREBASE}/scripts/runqemu-export-rootfs \ |
| 21 | file://tunctl.c \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | S = "${WORKDIR}" |
| 25 | |
| 26 | inherit nativesdk |
| 27 | |
| 28 | do_compile() { |
| 29 | ${CC} tunctl.c -o tunctl |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${bindir} |
| 34 | install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/ |
| 35 | install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/ |
| 36 | install tunctl ${D}${bindir}/ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | } |