Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Subversion (svn) version control system client" |
| 2 | HOMEPAGE = "http://subversion.apache.org" |
| 3 | SECTION = "console/network" |
| 4 | LICENSE = "Apache-2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=83206f39819e7a4dfca2ff7c190f6ce0" |
| 6 | |
| 7 | DEPENDS = "apr-util serf sqlite3 file lz4" |
| 8 | DEPENDS_append_class-native = " file-replacement-native" |
| 9 | |
| 10 | SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 11 | file://disable_macos.patch \ |
| 12 | file://0001-Fix-libtool-name-in-configure.ac.patch \ |
| 13 | file://serfmacro.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "0126847f9e8cb8ed0b90a6a18b203309" |
| 17 | SRC_URI[sha256sum] = "2cf23f3abb837dea0585a6b0ebd70e80e01f95bddef7c1aa097c18e3eaa6b584" |
| 18 | |
| 19 | inherit autotools pkgconfig gettext |
| 20 | |
| 21 | PACKAGECONFIG ?= "" |
| 22 | |
| 23 | PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl" |
| 24 | PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring" |
| 25 | |
| 26 | EXTRA_OECONF = " \ |
| 27 | --with-apr=${STAGING_BINDIR_CROSS} \ |
| 28 | --with-apr-util=${STAGING_BINDIR_CROSS} \ |
| 29 | --without-apxs \ |
| 30 | --without-berkeley-db \ |
| 31 | --without-swig \ |
| 32 | --disable-keychain \ |
| 33 | --with-utf8proc=internal \ |
| 34 | ac_cv_path_RUBY=none \ |
| 35 | " |
| 36 | |
| 37 | acpaths = "-I build/ -I build/ac-macros/" |
| 38 | |
| 39 | CPPFLAGS += "-P" |
| 40 | BUILD_CPPFLAGS += "-P" |
| 41 | |
| 42 | do_configure_prepend () { |
| 43 | rm -f ${S}/libtool |
| 44 | rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4 |
| 45 | rm -f ${S}/aclocal.m4 |
| 46 | sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4 |
| 47 | } |
| 48 | |
| 49 | #| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 50 | #| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it |
| 51 | #| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 52 | #| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed |
| 53 | #| make: *** [install-serf-lib] Error 1 |
| 54 | PARALLEL_MAKEINST = "" |
| 55 | |
| 56 | RDEPENDS_${PN} = "serf" |
| 57 | |
| 58 | BBCLASSEXTEND = "native" |