blob: 887b74163163a84499f308a5f3541a4c66e2e69c [file] [log] [blame]
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05301SUMMARY = "OpenPower OCC Control with MRW generated sensor IDs"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7inherit openpower-occ-control
Matt Spinler0a8ea632017-12-14 13:31:55 -06008inherit mrw-xml
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +05309
10PROVIDES += "virtual/openpower-occ-control-config-native"
11DEPENDS += "mrw-native mrw-perl-tools-native"
12
13# Generate a YAML files based on MRW input
14do_install_append() {
15 install -d ${YAML_DEST}/
16 ${STAGING_BINDIR_NATIVE}/perl-native/perl \
17 ${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060018 -i ${mrw_datadir}/${MRW_XML} \
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +053019 -o ${YAML_DEST}/occ_sensor.yaml
20}