Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "CPU burn app that loads the NEON coprocessor fully" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://burn.S;md5=823abc72c2cd448e87df9bc5355a4456" |
| 4 | |
| 5 | DL_DIR_append = "/${PN}-${PV}" |
| 6 | |
| 7 | # Ensure to make this available for machine which has neon |
| 8 | COMPATIBLE_MACHINE = "(${@bb.utils.contains("TUNE_FEATURES", "neon", "${MACHINE}", "Invalid!", d)})" |
| 9 | |
| 10 | SRC_URI = "http://hardwarebug.org/files/burn.S;name=mru \ |
| 11 | https://raw.githubusercontent.com/ssvb/cpuburn-arm/dd5c5ba58d2b0b23cfab4a286f9d3f5510000f20/cpuburn-a8.S;name=ssvb" |
| 12 | |
| 13 | SRC_URI[mru.md5sum] = "823abc72c2cd448e87df9bc5355a4456" |
| 14 | SRC_URI[mru.sha256sum] = "01d9fc04f83740c513c25401dcc89c11b2a5a6013e70bfca42b7b02129f88cd2" |
| 15 | SRC_URI[ssvb.md5sum] = "ba0ef2939a3b3b487523448c67544e94" |
| 16 | SRC_URI[ssvb.sha256sum] = "ce42ebdc71c876a33d9f7534355ef76cefa0d00ddb19ad69cf05a266c861d08d" |
| 17 | |
| 18 | S = "${WORKDIR}" |
| 19 | |
| 20 | do_compile() { |
| 21 | ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn |
| 22 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a8.S -o burn-neona8 |
| 23 | } |
| 24 | |
| 25 | do_install() { |
| 26 | install -d ${D}${bindir} |
| 27 | install -m 0755 ${S}/burn ${D}${bindir}/burn-neon |
| 28 | install -m 0755 ${S}/burn-neona8 ${D}${bindir}/ |
| 29 | } |
| 30 | |