Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "GNOME XSLT library" |
| 2 | HOMEPAGE = "http://xmlsoft.org/XSLT/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458" |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | DEPENDS = "libxml2" |
| 10 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 11 | SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \ |
| 12 | file://0001-Fix-security-framework-bypass.patch \ |
| 13 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "b3bd254a03e46d58f8ad1e4559cd2c2f" |
| 16 | SRC_URI[sha256sum] = "8e36605144409df979cab43d835002f63988f3dc94d5d3537c12796db90e38c8" |
| 17 | |
| 18 | UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar" |
| 19 | |
| 20 | S = "${WORKDIR}/libxslt-${PV}" |
| 21 | |
| 22 | BINCONFIG = "${bindir}/xslt-config" |
| 23 | |
| 24 | inherit autotools pkgconfig binconfig-disabled lib_package |
| 25 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | do_configure_prepend () { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header. |
| 28 | # This can be removed when upgrading to 1.1.34. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | sed -i -e 's/ansidecl.h//' ${S}/configure.ac |
| 30 | |
| 31 | # The timestamps in the 1.1.28 tarball are messed up causing this file to |
| 32 | # appear out of date. Touch it so that we don't try to regenerate it. |
| 33 | touch ${S}/doc/xsltproc.1 |
| 34 | } |
| 35 | |
| 36 | EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}" |
| 37 | # older versions of this recipe had ${PN}-utils |
| 38 | RPROVIDES_${PN}-bin += "${PN}-utils" |
| 39 | RCONFLICTS_${PN}-bin += "${PN}-utils" |
| 40 | RREPLACES_${PN}-bin += "${PN}-utils" |
| 41 | |
| 42 | # This is only needed until libxml can load the relocated catalog itself |
| 43 | do_install_append_class-native () { |
| 44 | create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog |
| 45 | } |
| 46 | |
| 47 | FILES_${PN} += "${libdir}/libxslt-plugins" |
| 48 | FILES_${PN}-dev += "${libdir}/xsltConf.sh" |
| 49 | |
| 50 | BBCLASSEXTEND = "native nativesdk" |