Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Publishes & browses available services on a link according to the Zeroconf / Bonjour protocol" |
| 2 | DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks." |
| 3 | HOMEPAGE = "http://developer.apple.com/networking/bonjour/" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf" |
| 6 | |
| 7 | RPROVIDES_${PN} += "libdns_sd.so" |
| 8 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 9 | SRC_URI = "https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${PV}.tar.gz \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | file://build.patch;patchdir=.. \ |
| 11 | file://mdns.service \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | file://0001-nss_mdns-Do-not-include-nss.h-when-libc-glibc.patch;patchdir=.. \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "e773f290a7d29f1072247985d6add2ff" |
| 15 | SRC_URI[sha256sum] = "e777b4d7dbf5eb1552cb80090ad1ede319067ab6e45e3990d68aabf6e8b3f5a0" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | |
| 17 | PARALLEL_MAKE = "" |
| 18 | |
| 19 | S = "${WORKDIR}/mDNSResponder-${PV}/mDNSPosix" |
| 20 | |
| 21 | EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'" |
| 22 | |
| 23 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 24 | |
| 25 | do_install () { |
| 26 | install -d ${D}${sbindir} |
| 27 | install -m 0755 build/prod/mdnsd ${D}${sbindir} |
| 28 | |
| 29 | install -d ${D}${libdir} |
| 30 | cp build/prod/libdns_sd.so ${D}${libdir}/libdns_sd.so.1 |
| 31 | chmod 0644 ${D}${libdir}/libdns_sd.so.1 |
| 32 | ln -s libdns_sd.so.1 ${D}${libdir}/libdns_sd.so |
| 33 | |
| 34 | install -d ${D}${includedir} |
| 35 | install -m 0644 ../mDNSShared/dns_sd.h ${D}${includedir} |
| 36 | |
| 37 | install -d ${D}${mandir}/man8 |
| 38 | install -m 0644 ../mDNSShared/mDNSResponder.8 ${D}${mandir}/man8/mdnsd.8 |
| 39 | |
| 40 | install -d ${D}${bindir} |
| 41 | install -m 0755 ../Clients/build/dns-sd ${D}${bindir} |
| 42 | |
| 43 | install -d ${D}${libdir} |
| 44 | oe_libinstall -C build/prod -so libnss_mdns-0.2 ${D}${libdir} |
| 45 | ln -s libnss_mdns-0.2.so ${D}${libdir}/libnss_mdns.so.2 |
| 46 | |
| 47 | install -d ${D}${sysconfdir} |
| 48 | install -m 0644 nss_mdns.conf ${D}${sysconfdir} |
| 49 | |
| 50 | install -d ${D}${mandir}/man5 |
| 51 | install -m 0644 nss_mdns.conf.5 ${D}${mandir}/man5 |
| 52 | |
| 53 | install -d ${D}${mandir}/man8 |
| 54 | install -m 0644 libnss_mdns.8 ${D}${mandir}/man8 |
| 55 | |
| 56 | install -d ${D}${systemd_unitdir}/system/ |
| 57 | install -m 0644 ${WORKDIR}/mdns.service ${D}${systemd_unitdir}/system/ |
| 58 | } |
| 59 | |
| 60 | pkg_postinst_${PN} () { |
| 61 | sed -e '/^hosts:/s/\s*\<mdns\>//' \ |
| 62 | -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns\3\4\5/' \ |
| 63 | -i $D/etc/nsswitch.conf |
| 64 | } |
| 65 | |
| 66 | pkg_prerm_${PN} () { |
| 67 | sed -e '/^hosts:/s/\s*\<mdns\>//' \ |
| 68 | -e '/^hosts:/s/\s*mdns//' \ |
| 69 | -i $D/etc/nsswitch.conf |
| 70 | } |
| 71 | |
| 72 | inherit systemd |
| 73 | |
| 74 | SYSTEMD_SERVICE_${PN} = "mdns.service" |
| 75 | |
| 76 | FILES_${PN} += "${systemd_unitdir}/system/mdns.service" |
| 77 | FILES_${PN} += "${libdir}/libdns_sd.so.1 \ |
| 78 | ${bindir}/dns-sd \ |
| 79 | ${libdir}/libnss_mdns-0.2.so \ |
| 80 | ${sysconfdir}/nss_mdns.conf" |
| 81 | |
| 82 | FILES_${PN}-dev += "${libdir}/libdns_sd.so \ |
| 83 | ${includedir}/dns_sd.h " |
| 84 | |
| 85 | FILES_${PN}-man += "${mandir}/man8/mdnsd.8 \ |
| 86 | ${mandir}/man5/nss_mdns.conf.5 \ |
| 87 | ${mandir}/man8/libnss_mdns.8" |
| 88 | |
| 89 | PACKAGES = "${PN} ${PN}-dev ${PN}-man ${PN}-dbg" |