Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Shows and manipulates data structure layout" |
| 2 | |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 5 | |
| 6 | DEPENDS = "elfutils zlib libbpf" |
| 7 | |
| 8 | # Depends on MACHINE_ARCH libbpf |
| 9 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 10 | COMPATIBLE_HOST = "(x86_64|i.86|aarch64).*-linux" |
| 11 | |
| 12 | SRCREV = "81558a5a996005df0d607dd33f74ec5b7bdb619d" |
| 13 | SRC_URI = "git://git.kernel.org/pub/scm/devel/pahole/pahole.git;branch=master \ |
| 14 | file://0002-Use-usr-bin-env-python3-instead-of-just-usr-bin-pyth.patch" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake pkgconfig |
| 19 | |
| 20 | PACKAGECONFIG[python3] = ",,python3-core,python3-core" |
| 21 | |
| 22 | EXTRA_OECMAKE = "-D__LIB=${@os.path.relpath(d.getVar('libdir'), d.getVar('prefix') + '/')} -DCMAKE_BUILD_TYPE=Release -DLIBBPF_EMBEDDED=OFF" |
| 23 | |
| 24 | FILES:${PN} = "${bindir}/pahole \ |
| 25 | ${libdir}/libdwarves.so* \ |
| 26 | ${libdir}/libdwarves_reorganize.so*" |
| 27 | |
| 28 | PACKAGES += "${PN}-extra" |
| 29 | FILES:${PN}-extra = "${datadir} ${bindir} ${libdir}/libdwarves_emit.so*" |
| 30 | RDEPENDS:${PN}-extra += "bash python3-core" |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |