Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "GTK+ icon theme" |
| 2 | HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/adwaita-icon-theme/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
| 6 | LICENSE = "LGPL-3.0 | CC-BY-SA-3.0" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c" |
| 8 | |
| 9 | inherit allarch autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even |
| 10 | |
| 11 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 12 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ |
| 13 | file://0001-Don-t-use-AC_CANONICAL_HOST.patch \ |
| 14 | file://0001-Run-installation-commands-as-shell-jobs.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "db3fd812821d72fdd9a3c7d622a95b35" |
| 18 | SRC_URI[sha256sum] = "6d752a2b1bc668483956d4485c39cad1642d9358e133ff689526e43674a4e1ce" |
| 19 | |
| 20 | DEPENDS += "librsvg-native" |
| 21 | |
| 22 | PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}" |
| 23 | |
| 24 | RREPLACES_${PN} = "gnome-icon-theme" |
| 25 | RCONFLICTS_${PN} = "gnome-icon-theme" |
| 26 | RPROVIDES_${PN} = "gnome-icon-theme" |
| 27 | |
| 28 | FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/" |
| 29 | FILES_${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \ |
| 30 | ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \ |
| 31 | ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \ |
| 32 | ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png" |
| 33 | FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \ |
| 34 | ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png \ |
| 35 | ${prefix}/share/icons/Adwaita/scalable/*/*-symbolic*.svg" |
| 36 | FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \ |
| 37 | ${prefix}/share/icons/Adwaita/512x512/" |
| 38 | FILES_${PN} = "${prefix}/share/icons/Adwaita/ \ |
| 39 | ${prefix}/share/pkgconfig/adwaita-icon-theme.pc" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |