blob: 272ae66f134ba697aa6fc85880a620248ecd54fa [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
3LICENSE = "LGPLv2.1+"
4DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
9
10# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
11SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
13 file://0001-app.cc-use-old-school-asignment-to-avoid-gcc-4.8-err.patch \
14 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015SRC_URI[archive.md5sum] = "de8181350dccb010e915e366bdd06d18"
16SRC_URI[archive.sha256sum] = "0f2657cef52accbfe56feede553155552d7c1984b1291838af3cb8cfc19b26af"
17
18ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
19
20# Instead of "inherit vala" we do the relevant settings here so we can
21# set DEPENDS based on PACKAGECONFIG.
22
23# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
24export STAGING_DATADIR
25# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
26export XDG_DATA_DIRS = "${STAGING_DATADIR}"
27
28# Help g-ir-scanner find the .so for linking
29do_compile_prepend() {
30 export GIR_EXTRA_LIBS_PATH="${B}/src/.libs"
31}
32
33# Package additional files
34FILES_${PN}-dev += "${datadir}/vala/vapi/*"
35
36PACKAGECONFIG ??= "gnutls"
37PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
38PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
39
40CFLAGS += "-D_GNU_SOURCE"
41
42# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
43# Use libtool-cross (which has a hack to prevent that) instead.
44EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
45
46PACKAGES =+ "libvte"
47FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"
Brad Bishop19323692019-04-05 15:28:33 -040048
49BBCLASSEXTEND = "native nativesdk"