Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 1 | SUMMARY = "Google Sys OEM commands" |
Patrick Venture | edb6192 | 2018-09-21 14:57:58 -0700 | [diff] [blame] | 2 | DESCRIPTION = "Google Sys OEM commands" |
Patrick Venture | 3adb97a | 2018-09-26 08:42:56 -0700 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 10 | inherit systemd |
| 11 | inherit obmc-phosphor-ipmiprovider-symlink |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "sdbusplus" |
| 15 | DEPENDS += "phosphor-logging" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 16 | DEPENDS += "phosphor-ipmi-host" |
Patrick Venture | 9668c75 | 2019-02-06 09:50:22 -0800 | [diff] [blame] | 17 | DEPENDS += "nlohmann-json" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 18 | |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 19 | S = "${WORKDIR}/git" |
| 20 | SRC_URI = "git://github.com/openbmc/google-ipmi-sys" |
Andrew Geissler | 27a22f7 | 2019-10-01 17:50:19 +0000 | [diff] [blame] | 21 | SRCREV = "cc53c847f14dd843bd7a7488822c1af52a5add11" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 22 | |
| 23 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 24 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 25 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 26 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 27 | |
| 28 | HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so" |
| 29 | |
| 30 | SYSTEMD_PACKAGES = "${PN}" |
| 31 | SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target" |
| 32 | |
| 33 | do_install_append() { |
| 34 | install -d ${D}${systemd_system_unitdir} |
| 35 | install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir} |
| 36 | } |