Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | |
| 2 | SUMMARY = "Kexec fast reboot tools" |
| 3 | DESCRIPTION = "Kexec is a fast reboot feature that lets you reboot to a new Linux kernel" |
| 4 | AUTHOR = "Eric Biederman" |
| 5 | HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/kexec/" |
| 6 | SECTION = "kernel/userland" |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a \ |
| 9 | file://kexec/kexec.c;beginline=1;endline=20;md5=af10f6ae4a8715965e648aa687ad3e09" |
| 10 | DEPENDS = "zlib xz" |
| 11 | |
| 12 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | file://kdump \ |
| 14 | file://kdump.conf \ |
| 15 | file://kdump.service \ |
| 16 | file://0001-powerpc-change-the-memory-size-limit.patch \ |
| 17 | file://0002-purgatory-Pass-r-directly-to-linker.patch \ |
| 18 | file://0003-kexec-ARM-Fix-add_buffer_phys_virt-align-issue.patch \ |
| 19 | file://0004-x86_64-Add-support-to-build-kexec-tools-with-x32-ABI.patch \ |
| 20 | file://0005-Disable-PIE-during-link.patch \ |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 21 | file://0006-kexec-arm-undefine-__NR_kexec_file_load-for-arm.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
| 24 | SRC_URI[md5sum] = "052458f0a35c2a3b0d2302caa3318e9f" |
| 25 | SRC_URI[sha256sum] = "913c8dee918e5855a4ba60d609371390978144b4c8d15d6446ca0057b7bc5e58" |
| 26 | |
| 27 | inherit autotools update-rc.d systemd |
| 28 | |
| 29 | export LDFLAGS = "-L${STAGING_LIBDIR}" |
| 30 | EXTRA_OECONF = " --with-zlib=yes" |
| 31 | |
| 32 | do_compile_prepend() { |
| 33 | # Remove the prepackaged config.h from the source tree as it overrides |
| 34 | # the same file generated by configure and placed in the build tree |
| 35 | rm -f ${S}/include/config.h |
| 36 | |
| 37 | # Remove the '*.d' file to make sure the recompile is OK |
| 38 | for dep in `find ${B} -type f -name '*.d'`; do |
| 39 | dep_no_d="`echo $dep | sed 's#.d$##'`" |
| 40 | # Remove file.d when there is a file.o |
| 41 | if [ -f "$dep_no_d.o" ]; then |
| 42 | rm -f $dep |
| 43 | fi |
| 44 | done |
| 45 | } |
| 46 | |
| 47 | do_install_append () { |
| 48 | install -d ${D}${sysconfdir}/sysconfig |
| 49 | install -m 0644 ${WORKDIR}/kdump.conf ${D}${sysconfdir}/sysconfig |
| 50 | |
| 51 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 52 | install -D -m 0755 ${WORKDIR}/kdump ${D}${sysconfdir}/init.d/kdump |
| 53 | fi |
| 54 | |
| 55 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 56 | install -D -m 0755 ${WORKDIR}/kdump ${D}${libexecdir}/kdump-helper |
| 57 | install -D -m 0644 ${WORKDIR}/kdump.service ${D}${systemd_unitdir}/system/kdump.service |
| 58 | sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_unitdir}/system/kdump.service |
| 59 | fi |
| 60 | } |
| 61 | |
| 62 | PACKAGES =+ "kexec kdump vmcore-dmesg" |
| 63 | |
| 64 | ALLOW_EMPTY_${PN} = "1" |
| 65 | RRECOMMENDS_${PN} = "kexec kdump vmcore-dmesg" |
| 66 | |
| 67 | FILES_kexec = "${sbindir}/kexec" |
| 68 | FILES_kdump = "${sbindir}/kdump \ |
| 69 | ${sysconfdir}/sysconfig/kdump.conf \ |
| 70 | ${sysconfdir}/init.d/kdump \ |
| 71 | ${libexecdir}/kdump-helper \ |
| 72 | ${systemd_unitdir}/system/kdump.service \ |
| 73 | " |
| 74 | |
| 75 | FILES_vmcore-dmesg = "${sbindir}/vmcore-dmesg" |
| 76 | |
| 77 | INITSCRIPT_PACKAGES = "kdump" |
| 78 | INITSCRIPT_NAME_kdump = "kdump" |
| 79 | INITSCRIPT_PARAMS_kdump = "start 56 2 3 4 5 . stop 56 0 1 6 ." |
| 80 | |
| 81 | SYSTEMD_PACKAGES = "kdump" |
| 82 | SYSTEMD_SERVICE_kdump = "kdump.service" |
| 83 | |
| 84 | SECURITY_PIE_CFLAGS_remove = "-fPIE -pie" |
| 85 | |
| 86 | COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|powerpc.*|mips.*)-(linux|freebsd.*)' |
| 87 | |
| 88 | INSANE_SKIP_${PN} = "arch" |