Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require recipes-graphics/xorg-app/xorg-app-common.inc |
| 2 | SUMMARY = "xterm is the standard terminal emulator for the X Window System" |
| 3 | DEPENDS = "libxaw xproto xextproto libxext libxau libxinerama libxpm ncurses" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=f02ab9ebda87b770ecf711dbb3784a33" |
| 6 | |
| 7 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz" |
| 8 | |
| 9 | SRC_URI[md5sum] = "9a6db7974aa4ccbb50eabebf72618467" |
| 10 | SRC_URI[sha256sum] = "7aeef9f29f6b95e09f481173c8c3053357bf5ffe162585647f690fd1707556df" |
| 11 | PACKAGECONFIG ?= "" |
| 12 | PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native" |
| 13 | |
| 14 | EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \ |
| 15 | --x-libraries=${STAGING_LIBDIR} \ |
| 16 | FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \ |
| 17 | --disable-imake \ |
| 18 | --disable-rpath-hack \ |
| 19 | --disable-setuid" |
| 20 | |
| 21 | B = "${S}" |
| 22 | |
| 23 | do_configure() { |
| 24 | gnu-configize --force |
| 25 | sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure |
| 26 | oe_runconf |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} += "/usr/lib/X11" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | |
| 31 | # busybox can supply resize too |
| 32 | inherit update-alternatives |
| 33 | |
| 34 | ALTERNATIVE_${PN} = "resize" |