Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Linux Kernel Crypto API User Space Interface Library" |
| 2 | HOMEPAGE = "http://www.chronox.de/libkcapi.html" |
| 3 | LICENSE = "BSD | GPL-2.0" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=14d5a68b28755c04ebdba226e888b157" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | |
| 6 | DEPENDS = "libtool" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | SRCREV = "5649050d201856bf06c8738b5d2aa1710c86ac2f" |
| 10 | PV = "1.1.5" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | SRC_URI = " \ |
| 12 | git://github.com/smuellerDD/libkcapi.git \ |
| 13 | " |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,," |
| 20 | |
| 21 | do_install_append() { |
| 22 | # bindir contains testapp and apps. However it is always created, even |
| 23 | # when no binaries are installed (empty bin_PROGRAMS in Makefile.am), |
| 24 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | |
| 26 | # Remove the generated binary checksum files |
| 27 | rm -f ${D}${bindir}/.*.hmac |
| 28 | rm -f ${D}${libdir}/.*.hmac |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | } |
| 30 | |
| 31 | CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare" |