Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 1 | SUMMARY = "Socket-based service activation daemon" |
| 2 | HOMEPAGE = "https://github.com/xinetd-org/xinetd" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things." |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 4 | |
| 5 | # xinetd is a BSD-like license |
| 6 | # Apple and Gentoo say BSD here. |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f" |
| 9 | |
| 10 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 11 | |
| 12 | SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \ |
| 13 | file://xinetd.init \ |
| 14 | file://xinetd.default \ |
| 15 | file://xinetd.service \ |
| 16 | " |
| 17 | |
| 18 | SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools update-rc.d systemd pkgconfig |
| 23 | |
| 24 | SYSTEMD_SERVICE_${PN} = "xinetd.service" |
| 25 | |
| 26 | INITSCRIPT_NAME = "xinetd" |
| 27 | INITSCRIPT_PARAMS = "defaults" |
| 28 | |
| 29 | PACKAGECONFIG ??= "tcp-wrappers" |
| 30 | PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers" |
| 31 | |
| 32 | CONFFILES_${PN} = "${sysconfdir}/xinetd.conf" |
| 33 | |
| 34 | do_install_append() { |
| 35 | install -d "${D}${sysconfdir}/init.d" |
| 36 | install -d "${D}${sysconfdir}/default" |
| 37 | install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd" |
| 38 | install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd" |
| 39 | |
| 40 | # Install systemd unit files |
| 41 | install -d ${D}${systemd_unitdir}/system |
| 42 | install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system |
| 43 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 44 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 45 | ${D}${systemd_unitdir}/system/xinetd.service |
| 46 | } |
| 47 | |
| 48 | RDEPENDS_${PN} += "perl" |