blob: 195c630903856fdd20c5a8fea72885bb26e2a639 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "PMU ROM for QEMU"
2DESCRIPTION = "The ZynqMP PMU ROM for QEMU emulation"
3HOMEPAGE = "http://www.xilinx.com"
4SECTION = "bsp"
5
6# The BSP package does not include any license information.
7LICENSE = "Proprietary"
8LICENSE_FLAGS = "xilinx"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
10
11COMPATIBLE_MACHINE = "zcu102-zynqmp"
12
13inherit deploy
14inherit xilinx-fetch-restricted
15
16BSP_NAME = "xilinx-zcu102"
17BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp"
18SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}"
19SRC_URI[md5sum] = "cea5f11761e7f38cbfcf0a07a19094e0"
20SRC_URI[sha256sum] = "7ac0ac3a5fb7dd162c0a922c66edb33b5737955ef6570a1a1d3b15b4344f7cc1"
21
22INHIBIT_DEFAULT_DEPS = "1"
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25do_compile() {
26 # Extract the rom into workdir
27 tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-${PV}/pre-built/linux/images/pmu_rom_qemu_sha3.elf -C ${S}
28 # tar preserves the tree, so use find to get the full path and move to to the root
29 for i in $(find ${S} -type f -name *.elf); do mv $i ${S}/pmu-rom.elf; done
30}
31
32do_install() {
33 :
34}
35
36do_deploy () {
37 install -D ${S}/pmu-rom.elf ${DEPLOYDIR}/pmu-rom.elf
38}
39
40addtask deploy before do_build after do_install
41