Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "execnet: rapid multi-Python deployment" |
| 5 | HOMEPAGE = "https://execnet.readthedocs.io/en/latest/" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" |
| 8 | |
| 9 | DEPENDS += "python3-pip-native" |
| 10 | |
| 11 | SRC_URI += "file://run-ptest \ |
| 12 | " |
| 13 | SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" |
| 14 | |
| 15 | inherit ptest pypi setuptools3 |
| 16 | |
| 17 | do_install_ptest() { |
| 18 | install -d ${D}${PTEST_PATH}/tests |
| 19 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/ |
| 20 | } |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | RDEPENDS:${PN}-ptest += "\ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 23 | python3-pytest \ |
| 24 | " |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |