Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Gstreamer validation tool" |
| 2 | DESCRIPTION = "A Tool to test GStreamer components" |
| 3 | HOMEPAGE = "https://gstreamer.freedesktop.org/documentation/gst-devtools/index.html" |
| 4 | SECTION = "multimedia" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1" |
| 7 | LIC_FILES_CHKSUM = "file://validate/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 8 | |
| 9 | #S = "${WORKDIR}/gst-devtools-${PV}" |
| 10 | |
| 11 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-${PV}.tar.xz \ |
| 12 | file://0001-connect-has-a-different-signature-on-musl.patch \ |
| 13 | " |
| 14 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "ffbd194c40912cb5e7fca2863648bf9dd8257b7af97d3a60c4fcd4efd8526ccf" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 16 | |
| 17 | DEPENDS = "json-glib glib-2.0 glib-2.0-native gstreamer1.0 gstreamer1.0-plugins-base" |
| 18 | RRECOMMENDS_${PN} = "git" |
| 19 | |
| 20 | FILES_${PN} += "${datadir}/gstreamer-1.0/* ${libdir}/gst-validate-launcher/* ${libdir}/gstreamer-1.0/*" |
| 21 | |
| 22 | inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection |
| 23 | |
| 24 | # TODO: put this in a gettext.bbclass patch |
| 25 | def gettext_oemeson(d): |
| 26 | if d.getVar('USE_NLS') == 'no': |
| 27 | return '-Dnls=disabled' |
| 28 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set |
| 29 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): |
| 30 | return '-Dnls=disabled' |
| 31 | return '-Dnls=enabled' |
| 32 | |
| 33 | EXTRA_OEMESON += " \ |
| 34 | -Ddoc=disabled \ |
| 35 | -Ddebug_viewer=disabled \ |
| 36 | -Dtests=disabled \ |
| 37 | -Dvalidate=enabled \ |
| 38 | ${@gettext_oemeson(d)} \ |
| 39 | " |
| 40 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 41 | do_install_append () { |
| 42 | for fn in ${bindir}/gst-validate-launcher \ |
| 43 | ${libdir}/gst-validate-launcher/python/launcher/config.py; do |
| 44 | sed -i -e 's,${B},/usr/src/debug/${PN},g' -e 's,${S},/usr/src/debug/${PN},g' ${D}$fn |
| 45 | done |
| 46 | } |
| 47 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 48 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 49 | GIR_MESON_DISABLE_FLAG = "disabled" |