Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "A portable version of the mg maintained by the OpenBSD team" |
| 2 | HOMEPAGE = "http://homepage.boetes.org/software/mg/" |
| 3 | LICENSE = "PD" |
| 4 | LIC_FILES_CHKSUM = "file://version.c;md5=1895eb37bf6bd79cdc5c89d8166fabfb" |
| 5 | DEPENDS = "ncurses libbsd" |
| 6 | SECTION = "console/editors" |
| 7 | |
| 8 | SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \ |
| 9 | file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \ |
| 10 | file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \ |
| 11 | " |
| 12 | SRC_URI_append_libc-musl = "\ |
| 13 | file://0001-Undefine-REGEX-for-musl-based-systems.patch \ |
| 14 | " |
| 15 | SRC_URI[md5sum] = "884388589fb38c2109ad9fed328be20a" |
| 16 | SRC_URI[sha256sum] = "0a3608b17c153960cb1d954ca3b62445a77c0c1a18aa5c8c58aba9f6b8d62aab" |
| 17 | |
| 18 | # CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?= |
| 19 | EXTRA_OEMAKE = "\ |
| 20 | 'CC=${CC}' \ |
| 21 | 'LDFLAGS=${LDFLAGS}' \ |
| 22 | \ |
| 23 | 'prefix=${prefix}' \ |
| 24 | 'bindir=${bindir}' \ |
| 25 | 'libdir=${libdir}' \ |
| 26 | 'includedir=${includedir}' \ |
| 27 | 'mandir=${mandir}' \ |
| 28 | 'PKG_CONFIG=pkg-config' \ |
| 29 | " |
| 30 | |
| 31 | CFLAGS += "-I${STAGING_INCDIR}/bsd" |
| 32 | |
| 33 | do_install () { |
| 34 | oe_runmake install DESTDIR=${D} |
| 35 | } |
| 36 | |
| 37 | inherit pkgconfig |