Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
| 12 | LICENSE = "BSD | GPLv2" |
| 13 | LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa" |
| 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "bison flex bison-native" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ |
| 20 | file://rename-yy_scan_string-manually.patch \ |
| 21 | file://manipulate-fds-instead-of-FILE.patch \ |
| 22 | " |
| 23 | SRC_URI[md5sum] = "31691e2eb82b2064f78536a3423c18d6" |
| 24 | SRC_URI[sha256sum] = "5d8fc9d9db9e04830d40bec9add04b21c05d466e0187d354815006fdd823cf15" |
| 25 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 26 | |
| 27 | S = "${WORKDIR}/acpica-unix2-${PV}" |
| 28 | |
| 29 | inherit update-alternatives |
| 30 | |
| 31 | ALTERNATIVE_PRIORITY = "100" |
| 32 | ALTERNATIVE_${PN} = "acpixtract" |
| 33 | |
| 34 | EXTRA_OEMAKE = "CC='${CC}' 'OPT_CFLAGS=-Wall'" |
| 35 | |
| 36 | do_install() { |
| 37 | install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl |
| 38 | install -D -p -m0755 generate/unix/bin*/acpibin ${D}${bindir}/acpibin |
| 39 | install -D -p -m0755 generate/unix/bin*/acpiexec ${D}${bindir}/acpiexec |
| 40 | install -D -p -m0755 generate/unix/bin*/acpihelp ${D}${bindir}/acpihelp |
| 41 | install -D -p -m0755 generate/unix/bin*/acpinames ${D}${bindir}/acpinames |
| 42 | install -D -p -m0755 generate/unix/bin*/acpisrc ${D}${bindir}/acpisrc |
| 43 | install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract |
| 44 | } |
| 45 | |
| 46 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 47 | PROVIDES = "iasl" |
| 48 | RPROVIDES_${PN} += "iasl" |
| 49 | RREPLACES_${PN} += "iasl" |
| 50 | RCONFLICTS_${PN} += "iasl" |
| 51 | |
| 52 | BBCLASSEXTEND = "native" |