Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | SECTION = "devel" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | DEPENDS = "autoconf-native automake-native" |
| 6 | |
| 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
| 8 | SRC_URI[md5sum] = "0d70833650a552e0af742882ba84f2ee" |
| 9 | SRC_URI[sha256sum] = "f371cbfd63f879065422b58fa6b81e21870cd791ef6e11d4528608204aa4dcfb" |
| 10 | |
| 11 | inherit autotools native |
| 12 | |
| 13 | EXTRA_OECONF = "--disable-nls" |
| 14 | |
| 15 | # We don't want to reconfigure things as it would require 'perlnative' to be |
| 16 | # used. |
| 17 | do_configure() { |
| 18 | oe_runconf |
| 19 | } |
| 20 | |
| 21 | do_install_append () { |
| 22 | # Make sure we use /usr/bin/env perl |
| 23 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 24 | } |