Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | BBCLASSEXTEND = "nativesdk" |
| 2 | |
| 3 | require qemu.inc |
| 4 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 5 | DEPENDS = "glib-2.0 zlib pixman bison-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 6 | |
| 7 | RDEPENDS_${PN}_class-target += "bash" |
| 8 | |
| 9 | EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}" |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 10 | EXTRA_OECONF_append_class-target_mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}" |
| 12 | |
| 13 | do_install_append_class-nativesdk() { |
| 14 | ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)} |
| 15 | } |
| 16 | |
| 17 | PACKAGECONFIG ??= " \ |
| 18 | fdt sdl kvm \ |
| 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \ |
| 20 | " |
| 21 | PACKAGECONFIG_class-nativesdk ??= "fdt sdl kvm" |