Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Atheros 6K Wifi configuration utility" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://wmiconfig.c;endline=19;md5=4394a56bca1c5b2446c9f8e406c82911" |
| 4 | SECTION = "console/network" |
| 5 | SRCREV = "5394" |
| 6 | PV = "0.0.0+svnr${SRCPV}" |
| 7 | PR = "r2" |
| 8 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=AR6kSDK.build_sw.18;protocol=http \ |
| 10 | file://0001-makefile-Pass-CFLAGS-to-compile.patch \ |
| 11 | file://0002-fix-err-API-to-have-format-string.patch \ |
| 12 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | S = "${WORKDIR}/AR6kSDK.build_sw.18/host/tools/wmiconfig" |
| 14 | |
| 15 | CLEANBROKEN = "1" |
| 16 | |
| 17 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 18 | |
| 19 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 wmiconfig ${D}${bindir} |
| 24 | } |
| 25 | |