Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "pandas library for high-performance data analysis tools" |
| 2 | DESCRIPTION = "pandas is an open source, BSD-licensed library providing \ |
| 3 | high-performance, easy-to-use data structures and data analysis tools for \ |
| 4 | the Python programming language." |
| 5 | HOMEPAGE = "http://pandas.pydata.org/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2" |
| 8 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "2ff7788468e75917574f080cd4681b27e1a7bf36461fe968b49a87b5a54d007c" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \ |
| 15 | " |
| 16 | |
| 17 | CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-json \ |
| 21 | ${PYTHON_PN}-numpy \ |
| 22 | ${PYTHON_PN}-dateutil \ |
| 23 | ${PYTHON_PN}-dateutil-zoneinfo \ |
| 24 | ${PYTHON_PN}-pytz \ |
| 25 | ${PYTHON_PN}-profile \ |
| 26 | " |