Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 1 | SUMMARY = "AppStream is a collaborative effort for making machine-readable software metadata easily available." |
| 2 | HOMEPAGE = "https://github.com/ximion/appstream" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=435ed639f84d4585d93824e7da3d85da" |
| 5 | |
| 6 | DEPENDS = " \ |
| 7 | appstream-native \ |
| 8 | curl-native \ |
| 9 | curl \ |
| 10 | docbook-xml-dtd4-native \ |
| 11 | gperf-native \ |
| 12 | glib-2.0 \ |
| 13 | libyaml \ |
| 14 | libxml2 \ |
| 15 | libxmlb \ |
| 16 | libxslt-native \ |
| 17 | itstool-native \ |
| 18 | docbook-xsl-stylesheets-native \ |
| 19 | python3-pygments-native \ |
| 20 | " |
| 21 | |
| 22 | inherit meson gobject-introspection gettext gtk-doc pkgconfig vala |
| 23 | |
| 24 | GIR_MESON_OPTION = "gir" |
| 25 | GTKDOC_MESON_OPTION = "apidocs" |
| 26 | |
| 27 | SRC_URI = " \ |
| 28 | https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz \ |
| 29 | file://0001-remove-hardcoded-path.patch \ |
| 30 | file://0001-meson-do-not-rely-on-an-exe-wrapper.patch \ |
| 31 | " |
| 32 | SRC_URI[sha256sum] = "081c917646e94d7221c9e4aae54dacda95a27c607fa93cd8e6344a2b318b98b1" |
| 33 | |
| 34 | S = "${WORKDIR}/AppStream-${PV}" |
| 35 | |
| 36 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 37 | |
| 38 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" |
| 39 | PACKAGECONFIG[stemming] = "-Dstemming=true,-Dstemming=false,libstemmer" |
| 40 | |
| 41 | FILES:${PN} += "${datadir}" |
| 42 | |
| 43 | EXTRA_OEMESON += "${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dvapi=true', '-Dvapi=false', d)}" |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |