Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ |
| 2 | application developers the full power and flexibility of SQL" |
| 3 | HOMEPAGE = "http://www.sqlalchemy.org/" |
| 4 | LICENSE = "MIT" |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 6 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "86a6ed69a71fe6b88bf9331594fa390a2adda4a49b5c06f98e47bf0d392534f8" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "SQLAlchemy" |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | python3-asyncio \ |
| 14 | python3-compression \ |
| 15 | python3-json \ |
| 16 | python3-logging \ |
| 17 | python3-netclient \ |
| 18 | python3-numbers \ |
| 19 | python3-pickle \ |
| 20 | python3-profile \ |
| 21 | python3-threading \ |
| 22 | python3-typing-extensions \ |
| 23 | " |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |