Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Traitlets Python config system" |
| 2 | HOMEPAGE = "https://github.com/ipython/traitlets" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=13bed0ee6f46a6f6dbf1f9f9572f250a" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "8cdd83c040dab7d1dee822678e5f5d100b514f7b72b01615b26fc5718916fdf9" |
| 7 | |
| 8 | inherit pypi python_hatchling ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | python3-argcomplete \ |
| 16 | bash \ |
| 17 | python3-mypy \ |
| 18 | python3-pytest \ |
| 19 | python3-pytest-mock \ |
| 20 | python3-unittest-automake-output \ |
| 21 | " |
| 22 | |
| 23 | do_install_ptest() { |
| 24 | install -d ${D}${PTEST_PATH}/tests |
| 25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 26 | } |