Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "a utility to add users/groups to the system" |
| 2 | DESCRIPTION = "adduser, addgroup - add a user or group to the system" |
| 3 | HOMEPAGE = "http://alioth.debian.org/projects/adduser/" |
| 4 | SECTION = "base/utils" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=caed49ab166f22ef31bf1127f558d0ef" |
| 8 | |
| 9 | SRC_URI = "http://ftp.de.debian.org/debian/pool/main/a/${BPN}/${BPN}_${PV}.tar.xz \ |
| 10 | file://adduser-add-M-option-for-useradd.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "e042a5842b8f24312d6f5a99a1af8f2c" |
| 14 | SRC_URI[sha256sum] = "72d811ad3ba17d2794b14d19acd1d6b57f9dd31d9250d51e786895dee2daeac0" |
| 15 | |
| 16 | inherit cpan-base update-alternatives |
| 17 | |
| 18 | S = "${WORKDIR}/${BPN}" |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${sbindir} |
| 22 | install -m 0755 ${S}/adduser ${D}${sbindir} |
| 23 | install -m 0755 ${S}/deluser ${D}${sbindir} |
| 24 | |
| 25 | install -D -m 0644 ${S}/AdduserCommon.pm ${D}${libdir}/perl/${@get_perl_version(d)}/Debian/AdduserCommon.pm |
| 26 | sed -i -e "s/VERSION/${PV}/" ${D}${sbindir}/* |
| 27 | |
| 28 | install -d ${D}/${sysconfdir} |
| 29 | install -m 0644 ${S}/*.conf ${D}/${sysconfdir} |
| 30 | |
| 31 | install -d ${D}${mandir}/man5 |
| 32 | install -m 0644 ${S}/doc/*.conf.5 ${D}${mandir}/man5 |
| 33 | install -d ${D}${mandir}/man8 |
| 34 | install -m 0644 ${S}/doc/*.8 ${D}${mandir}/man8 |
| 35 | install -d ${D}${docdir}/${BPN} |
| 36 | cp -rf ${S}/examples ${D}${docdir}/${BPN} |
| 37 | } |
| 38 | |
| 39 | RDEPENDS_${PN} += "\ |
| 40 | shadow \ |
| 41 | perl-module-getopt-long \ |
| 42 | perl-module-overloading \ |
| 43 | perl-module-file-find \ |
| 44 | perl-module-file-temp \ |
| 45 | " |
| 46 | |
| 47 | ALTERNATIVE_${PN} = "adduser deluser addgroup delgroup" |
| 48 | ALTERNATIVE_PRIORITY = "60" |
| 49 | ALTERNATIVE_LINK_NAME[adduser] = "${sbindir}/adduser" |
| 50 | ALTERNATIVE_LINK_NAME[deluser] = "${sbindir}/deluser" |
| 51 | ALTERNATIVE_LINK_NAME[addgroup] = "${sbindir}/addgroup" |
| 52 | ALTERNATIVE_LINK_NAME[delgroup] = "${sbindir}/delgroup" |
| 53 | ALTERNATIVE_TARGET[addgroup] = "${sbindir}/adduser.${BPN}" |
| 54 | ALTERNATIVE_TARGET[delgroup] = "${sbindir}/deluser.${BPN}" |