Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit." |
| 2 | DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \ |
| 3 | It is written using the Boost Spirit parser generator. If you are \ |
| 4 | already using Boost, you can use JSON Spirit without any additional \ |
| 5 | dependencies." |
| 6 | HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx" |
| 7 | SECTION = "libs" |
| 8 | PRIORITY = "optional" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9" |
| 11 | |
| 12 | SRC_URI = "file://json_spirit_v${PV}.zip \ |
| 13 | file://0001-Adjust-the-cmake-files.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | file://0001-Link-to-libatomic.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/json_spirit_v${PV}" |
| 18 | |
| 19 | DEPENDS = "boost" |
| 20 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | inherit cmake |
| 22 | |
| 23 | FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake" |
| 24 | |
| 25 | BBCLASSEXTEND = "nativesdk" |