blob: 8ab35d224b54e13e100d372f3e3bac24da89d74a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
7SRC_URI = "git://github.com/miloyip/rapidjson.git;nobranch=1 \
8 file://remove-march-native-from-CMAKE_CXX_FLAGS.patch \
9"
10
11SRCREV = "e5635fb27feab7f6e8d7b916aa20ad799045a641"
12
13PV = "1.1.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17inherit cmake
18
19EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF"
20
21# RapidJSON is a header-only C++ library, so the main package will be empty.
22
23FILES_${PN}-dev += "${libdir}/cmake"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024RDEPENDS_${PN}-dev = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26BBCLASSEXTEND = "native nativesdk"