Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Diod is a user space server for the kernel v9fs client." |
| 2 | DESCRIPTION = "\ |
| 3 | Diod is a user space server for the kernel v9fs client (9p.ko, 9pnet.ko). \ |
| 4 | Although the kernel client supports several 9P variants, diod only supports \ |
| 5 | 9P2000.L, and only in its feature-complete form, as it appeared in 2.6.38." |
| 6 | SECTION = "console/network" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 10 | |
| 11 | PV = "1.0.24+git${SRCPV}" |
| 12 | SRCREV = "0ea3fe3d829b5085307cd27a512708d99ef48199" |
| 13 | SRC_URI = "git://github.com/chaos/diod.git;protocol=git \ |
| 14 | file://diod \ |
| 15 | file://diod.conf \ |
| 16 | file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \ |
| 17 | file://0002-auto.diod.in-remove-bashisms.patch \ |
| 18 | " |
| 19 | DEPENDS = "libcap ncurses tcp-wrappers lua" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools systemd |
| 24 | |
| 25 | do_install_append () { |
| 26 | # install our init based on start-stop-daemon |
| 27 | install -D -m 0755 ${WORKDIR}/diod ${D}${sysconfdir}/init.d/diod |
| 28 | # install a real(not commented) configuration file for diod |
| 29 | install -m 0644 ${WORKDIR}/diod.conf ${D}${sysconfdir}/diod.conf |
| 30 | } |
| 31 | |
| 32 | FILES_${PN} += "${systemd_unitdir}" |