Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Framebuffer image and doc viewer tools" |
| 2 | DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \ |
| 3 | with the main focus being photos." |
| 4 | HOMEPAGE = "http://linux.bytesex.org/fbida/" |
| 5 | AUTHOR = "Gerd Hoffmann" |
| 6 | SECTION = "utils" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 11 | DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman poppler libepoxy cairo" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \ |
| 14 | file://0001-Avoid-using-host-path.patch \ |
| 15 | file://fix-preprocessor.patch \ |
| 16 | file://support-jpeg-turbo.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 17 | file://cairo-weak-detect.patch \ |
| 18 | file://fbida-gcc10.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "95b7c01556cb6ef9819f358b314ddfeb8a4cbe862b521a3ed62f03d163154438" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 22 | inherit pkgconfig features_check |
| 23 | |
| 24 | # Depends on libepoxy |
| 25 | REQUIRED_DISTRO_FEATURES = "opengl" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile" |
| 28 | |
| 29 | PACKAGECONFIG ??= "gif png curl" |
| 30 | PACKAGECONFIG[curl] = ",,curl" |
| 31 | PACKAGECONFIG[gif] = ",,giflib" |
| 32 | PACKAGECONFIG[png] = ",,libpng" |
| 33 | PACKAGECONFIG[tiff] = ",,tiff" |
| 34 | PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif" |
| 35 | PACKAGECONFIG[webp] = ",,libwebp" |
| 36 | PACKAGECONFIG[lirc] = ",,lirc" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 37 | # This can only be enabled when cairo has egl enabled in its packageconfig support too |
| 38 | PACKAGECONFIG[egl] = ",," |
| 39 | |
| 40 | EXTRA_OEMAKE += ""${@bb.utils.contains('PACKAGECONFIG', 'egl', 'HAVE_CAIRO_GL=yes', 'HAVE_CAIRO_GL=no', d)}"" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | |
| 42 | do_compile() { |
| 43 | sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile |
| 44 | sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 45 | sed -i -e 's: cpp: ${CPP}:' ${S}/GNUmakefile |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | |
| 47 | # Be sure to respect preferences (force to "no") |
| 48 | # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 49 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 50 | sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 51 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 52 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 53 | sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 54 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 55 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 56 | sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 57 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 58 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 59 | sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 60 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 61 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 62 | sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 63 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 64 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 65 | sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 66 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 67 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 68 | sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 69 | fi |
| 70 | |
| 71 | oe_runmake |
| 72 | } |
| 73 | |
| 74 | do_install() { |
| 75 | oe_runmake 'DESTDIR=${D}' install |
| 76 | } |
| 77 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 78 | RDEPENDS:${PN} = "ttf-dejavu-sans-mono bash" |