blob: 24d9ad2720b2547c876faac7721755ee946dbc0a [file] [log] [blame]
George Liud335b652024-06-03 19:09:16 +08001SUMMARY = "IEISystems OEM IPMI commands"
2DESCRIPTION = "IEISystems OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7SRC_URI = "git://github.com/openbmc/iei-ipmi-oem;branch=master;protocol=https"
Andrew Geissler039ca6f2024-08-20 06:30:14 -05008SRCREV = "93b6a33320ab0494d4732c1190c6821ec7149cac"
George Liud335b652024-06-03 19:09:16 +08009
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS += "phosphor-ipmi-host"
14DEPENDS += "phosphor-logging"
15
16inherit meson pkgconfig
17inherit obmc-phosphor-ipmiprovider-symlink
18
19PACKAGECONFIG ??= ""
20
21FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
23FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
24FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"