Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SECTION = "console/utils" |
| 2 | SUMMARY = "A free SOCKS server" |
| 3 | DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\ |
| 4 | implementing RFC 1928 and related standards. It is a flexible product\ |
| 5 | that can be used to provide convenient and secure network\ |
| 6 | connectivity. Once installed, Dante can in most cases be made\ |
| 7 | transparent to clients, providing functionality somewhat similar to\ |
| 8 | what could be described as a non-transparent Layer 4 router." |
| 9 | HOMEPAGE = "http://www.inet.no/dante/" |
| 10 | |
| 11 | LICENSE = "BSD-3-Clause" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=221118dda731fe93a85d0ed973467249" |
| 13 | |
| 14 | SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \ |
| 15 | " |
| 16 | SRC_URI[md5sum] = "68c2ce12119e12cea11a90c7a80efa8f" |
| 17 | SRC_URI[sha256sum] = "b6d232bd6fefc87d14bf97e447e4fcdeef4b28b16b048d804b50b48f261c4f53" |
| 18 | |
| 19 | # without --without-gssapi, config.log will contain reference to /usr/lib |
| 20 | # as a consequence of GSSAPI path being set to /usr by default. |
| 21 | # --with-gssapi-path=PATH specify gssapi path |
| 22 | # --without-gssapi disable gssapi support |
| 23 | # --enable-release build prerelease as full release |
| 24 | EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}" |
| 25 | |
| 26 | DEPENDS += "flex-native bison-native libpam" |
| 27 | |
| 28 | inherit autotools-brokensep distro_features_check |
| 29 | |
| 30 | REQUIRED_DISTRO_FEATURES = "pam" |
| 31 | |
| 32 | EXTRA_AUTORECONF = "-I ${S}" |
| 33 | |
| 34 | PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap" |
| 35 | PACKAGECONFIG[krb5] = ",--without-krb5,krb5" |
| 36 | |
| 37 | PACKAGECONFIG ??= "" |
| 38 | |
| 39 | do_install_append() { |
| 40 | install -d ${D}${sysconfdir} |
| 41 | cp ${S}/example/sock[sd].conf ${D}${sysconfdir} |
| 42 | } |
| 43 | |
| 44 | PACKAGES =+ "${PN}-sockd ${PN}-libdsocks " |
| 45 | |
| 46 | FILES_${PN}-libdsocks = "${libdir}/libdsocks.so" |
| 47 | FILES_${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf" |
| 48 | |
| 49 | INSANE_SKIP_${PN}-libdsocks = "dev-elf" |