Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "pam-ssh-agent-auth" |
| 2 | DESCRIPTION = "A PAM module which permits authentication via ssh-agent." |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "openssl & BSD" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \ |
| 7 | file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \ |
| 8 | " |
| 9 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2 \ |
| 11 | file://0001-Adapt-to-OpenSSL-1.1.1.patch \ |
| 12 | file://0002-Check-against-the-correct-OPENSSL_VERSION_NUMBER.patch \ |
| 13 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d" |
| 15 | SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763" |
| 16 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | DEPENDS += "libpam openssl" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | inherit distro_features_check |
| 20 | REQUIRED_DISTRO_FEATURES = "pam" |
| 21 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | # This gets us ssh-agent, which we are almost certain to want. |
| 23 | # |
| 24 | RDEPENDS_${PN} += "openssh-misc" |
| 25 | |
| 26 | # Kind of unfortunate to have underscores in the name. |
| 27 | # |
| 28 | S = "${WORKDIR}/pam_ssh_agent_auth-${PV}" |
| 29 | |
| 30 | inherit autotools-brokensep |
| 31 | |
| 32 | # Avoid autoreconf. Override the --libexec oe_runconf specifies so that |
| 33 | # the module is put with the other pam modules. Because it cannot, in general, |
| 34 | # do a runtime test, configure wants to use rpl_malloc() and rpl_realloc() |
| 35 | # instead of malloc() and realloc(). We set variables to tell it not to because |
| 36 | # these functions do not exist. |
| 37 | # |
| 38 | do_configure () { |
| 39 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 40 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
| 41 | oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \ |
| 42 | ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes |
| 43 | } |
| 44 | |
| 45 | # Link with CC. Configure cannot figure out the correct AR. |
| 46 | # |
| 47 | do_compile () { |
| 48 | oe_runmake LD="${CC}" AR="${AR}" |
| 49 | } |
| 50 | |
| 51 | # This stuff is not any place looked at by default. |
| 52 | # |
| 53 | FILES_${PN} += "${base_libdir}/security/pam*" |
| 54 | FILES_${PN}-dbg += "${base_libdir}/security/.debug" |