Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "GTK+2 standard themes" |
| 2 | HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
| 6 | LICENSE = "LGPL-2.1" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 8 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 9 | # Upstream renamed this package to gnome-themes-extra at some point |
| 10 | BPN = "gnome-themes-extra" |
| 11 | |
| 12 | inherit gnomebase gettext gtk-icon-cache upstream-version-is-even distro_features_check |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | |
| 14 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
| 15 | |
| 16 | DEPENDS += "intltool-native gtk+" |
| 17 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 18 | SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826" |
| 19 | SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 20 | |
| 21 | EXTRA_OECONF = "--disable-gtk3-engine" |
| 22 | |
| 23 | do_install_append() { |
| 24 | # Only building Adwaita, remove highcontrast files |
| 25 | rm -rf ${D}${prefix}/share/themes/HighContrast \ |
| 26 | ${D}${prefix}/share/icons |
| 27 | |
| 28 | # The libtool archive file is unneeded with shared libs on modern Linux |
| 29 | rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la |
| 30 | } |
| 31 | |
| 32 | # There could be gnome-theme-highcontrast as well but that requires |
| 33 | # gtk+3 and includes lots of icons (is also broken with B != S). |
| 34 | PACKAGES += "gnome-theme-adwaita \ |
| 35 | gnome-theme-adwaita-dark \ |
| 36 | " |
| 37 | |
| 38 | FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \ |
| 39 | ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so" |
| 40 | |
| 41 | FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark" |
| 42 | RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita" |
| 43 | |
| 44 | # gnome-themes-standard is empty and doesn't exist |
| 45 | RDEPENDS_${PN}-dev = "" |