Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Common X11 scripts and support files" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | PR = "r9" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
| 7 | # we are using a gpe-style Makefile |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | inherit distro_features_check gpe |
| 9 | |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14" |
| 13 | SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210" |
| 14 | |
| 15 | SRC_URI_append = " \ |
| 16 | file://0001-COPYING-add-GPLv2-license-file.patch \ |
| 17 | file://0002-add-setdpi-Xinit.d-script.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | file://0006-add-support-for-etc-X11-xserver-system.patch \ |
| 19 | file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \ |
| 20 | file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \ |
| 21 | file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \ |
| 22 | file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \ |
| 23 | file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \ |
| 24 | file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \ |
| 25 | file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | file://0015-xserver-common-disable-TCP-connections.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | file://0001-Don-t-install-Xsession-or-Xserver.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | do_install_append() { |
| 31 | sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common |
| 32 | # Rename all Xsession files not ending with .sh |
| 33 | # Unfortunatelly when xinput-calibrator was moved to oe-core |
| 34 | # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it |
| 35 | # last, not respecting numbers for sorting them |
| 36 | for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do |
| 37 | echo $i | grep '.sh$' || mv $i $i.sh |
| 38 | done |
| 39 | } |
| 40 | |
| 41 | RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator" |
| 42 | |
| 43 | RCONFLICTS_${PN} = "xserver-kdrive-common x11-common" |
| 44 | RREPLACES_${PN} = "xserver-kdrive-common x11-common" |
| 45 | |