Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \ |
| 2 | Provides gRPC libraries for multiple languages written on top of shared C core library \ |
| 3 | (C++, Node.js, Python, Ruby, Objective-C, PHP, C#)" |
| 4 | HOMEPAGE = "https://github.com/grpc/grpc" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "Apache-2" |
| 7 | |
| 8 | DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl" |
| 9 | DEPENDS_append_class-target = " gtest grpc-native " |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 12 | |
| 13 | SRC_URI = "https://github.com/grpc/grpc/archive/v${PV}.tar.gz \ |
| 14 | file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \ |
| 15 | file://0004-CMakeLists.txt-Find-c-ares-in-target-sysroot-alone.patch \ |
| 16 | " |
| 17 | SRC_URI[md5sum] = "b565fa6787e42f4969395870c2ad436e" |
| 18 | SRC_URI[sha256sum] = "df9168da760fd2ee970c74c9d1b63377e0024be248deaa844e784d0df47599de" |
| 19 | |
| 20 | SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch" |
| 21 | |
| 22 | inherit cmake |
| 23 | |
| 24 | EXTRA_OECMAKE = " \ |
| 25 | -DgRPC_CARES_PROVIDER=package \ |
| 26 | -DgRPC_ZLIB_PROVIDER=package \ |
| 27 | -DgRPC_SSL_PROVIDER=package \ |
| 28 | -DgRPC_PROTOBUF_PROVIDER=package \ |
| 29 | -DgRPC_GFLAGS_PROVIDER=package \ |
| 30 | -DgRPC_INSTALL=1 \ |
| 31 | -DBUILD_SHARED_LIBS=ON \ |
| 32 | " |
| 33 | |
| 34 | FILES_${PN}-dev += "${libdir}/cmake" |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |