Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "low-level tool handling Linux filesystem encryption" |
| 2 | DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \ |
| 3 | policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \ |
| 4 | For a tool that presents a higher level interface and manages metadata, key \ |
| 5 | generation, key wrapping, PAM integration, and passphrase hashing, see \ |
| 6 | fscrypt (https://github.com/google/fscrypt)." |
| 7 | HOMEPAGE = "https://github.com/google/fscryptctl" |
| 8 | SECTION = "base" |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
| 12 | SRCREV = "e4c4d0984dee2531897e13c32a18d5e54a2a4aa6" |
| 13 | SRC_URI = "git://github.com/google/fscryptctl.git" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_install() { |
| 18 | oe_runmake DESTDIR=${D}${bindir} install |
| 19 | } |
| 20 | |
| 21 | RRECOMMENDS_${PN} += "\ |
| 22 | keyutils \ |
| 23 | kernel-module-cbc \ |
| 24 | kernel-module-cts \ |
| 25 | kernel-module-ecb \ |
| 26 | kernel-module-xts \ |
| 27 | " |