Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | # Class for use in BBCLASSEXTEND to make it easier to have a single recipe that |
| 2 | # can build both stable tarballs and snapshots from upstream source |
| 3 | # repositories. |
| 4 | # |
| 5 | # Usage: |
| 6 | # BBCLASSEXTEND = "devupstream:target" |
| 7 | # SRC_URI_class-devupstream = "git://git.example.com/example" |
| 8 | # SRCREV_class-devupstream = "abcdef" |
| 9 | # |
| 10 | # If the first entry in SRC_URI is a git: URL then S is rewritten to |
| 11 | # WORKDIR/git. |
| 12 | # |
| 13 | # There are a few caveats that remain to be solved: |
| 14 | # - You can't build native or nativesdk recipes using for example |
| 15 | # devupstream:native, you can only build target recipes. |
| 16 | # - If the fetcher requires native tools (such as subversion-native) then |
| 17 | # bitbake won't be able to add them automatically. |
| 18 | |
| 19 | CLASSOVERRIDE .= ":class-devupstream" |
| 20 | |
| 21 | python devupstream_virtclass_handler () { |
| 22 | # Do nothing if this is inherited, as it's for BBCLASSEXTEND |
| 23 | if "devupstream" not in (d.getVar('BBCLASSEXTEND') or ""): |
| 24 | bb.error("Don't inherit devupstream, use BBCLASSEXTEND") |
| 25 | return |
| 26 | |
| 27 | variant = d.getVar("BBEXTENDVARIANT") |
| 28 | if variant not in ("target"): |
| 29 | bb.error("Pass the variant when using devupstream, for example devupstream:target") |
| 30 | return |
| 31 | |
| 32 | # Develpment releases are never preferred by default |
| 33 | d.setVar("DEFAULT_PREFERENCE", "-1") |
| 34 | |
| 35 | uri = bb.fetch2.URI(d.getVar("SRC_URI").split()[0]) |
| 36 | |
| 37 | if uri.scheme == "git": |
| 38 | d.setVar("S", "${WORKDIR}/git") |
| 39 | |
| 40 | # Modify the PV if the recipe hasn't already overridden it |
| 41 | pv = d.getVar("PV") |
| 42 | proto_marker = "+" + uri.scheme |
| 43 | if proto_marker not in pv: |
| 44 | d.setVar("PV", pv + proto_marker + "${SRCPV}") |
| 45 | } |
| 46 | |
| 47 | addhandler devupstream_virtclass_handler |
| 48 | devupstream_virtclass_handler[eventmask] = "bb.event.RecipePreFinalise" |