Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Host side USB console utilities" |
| 2 | DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus." |
| 3 | HOMEPAGE = "http://www.linux-usb.org" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPL-2.0-or-later & (GPL-2.0-only | GPL-3.0-only)" |
| 7 | # License files went missing in 010, when 011 is released add LICENSES/* back |
| 8 | LIC_FILES_CHKSUM = "file://lsusb.c;endline=1;md5=7226e442a172bcf25807246d7ef1eba1 \ |
| 9 | file://lsusb.py.in;beginline=2;endline=2;md5=c443ada211d701156e42ea36d41625b3 \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "libusb1 virtual/libiconv udev" |
| 13 | |
| 14 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "2b8140664578f39c3f6f0166a1b950f8655304e63e3d7f89899acb99bc5cb8e7" |
| 17 | |
| 18 | inherit autotools pkgconfig update-alternatives |
| 19 | |
| 20 | ALTERNATIVE:${PN} = "lsusb" |
| 21 | ALTERNATIVE_PRIORITY = "100" |
| 22 | |
| 23 | # The binaries are mostly GPL-2.0-or-later apart from lsusb.py which is |
| 24 | # GPL-2.0-only or GPL-3.0-only. |
| 25 | LICENSE:${PN} = "GPL-2.0-or-later" |
| 26 | LICENSE:${PN}-python = "GPL-2.0-only | GPL-3.0-only" |
| 27 | |
| 28 | RRECOMMENDS:${PN} = "udev-hwdb" |
| 29 | |
| 30 | PACKAGE_BEFORE_PN =+ "${PN}-python" |
| 31 | FILES:${PN}-python += "${bindir}/lsusb.py" |
| 32 | RDEPENDS:${PN}-python = "python3-core" |