Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME library for reading .desktop files" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2 & LGPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 5 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 6 | |
| 7 | BPN = "gnome-desktop" |
| 8 | |
| 9 | GNOMEBASEBUILDCLASS = "meson" |
| 10 | |
| 11 | inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check |
| 12 | |
| 13 | # gobject-introspection is mandatory and cannot be configured |
| 14 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 15 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| 16 | |
| 17 | SRC_URI[archive.md5sum] = "1cbcb9d9a5159447b9a45079c6157ca5" |
| 18 | SRC_URI[archive.sha256sum] = "ef13203bed721d271227d9928d91937733c312ef79b6f5c00b6c02e8e0b2fa21" |
| 19 | |
| 20 | SRC_URI += " \ |
| 21 | file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \ |
| 22 | file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \ |
| 23 | " |
| 24 | |
| 25 | DEPENDS += "gsettings-desktop-schemas virtual/libx11 gtk+3 startup-notification xkeyboard-config iso-codes udev" |
| 26 | |
| 27 | inherit features_check gtk-doc |
| 28 | REQUIRED_DISTRO_FEATURES += "x11" |
| 29 | |
| 30 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 31 | EXTRA_OEMESON = "-Ddesktop_docs=false" |
| 32 | |
| 33 | PACKAGES =+ "libgnome-desktop3" |
| 34 | FILES_libgnome-desktop3 = "${libdir}/lib*${SOLIBS} ${datadir}/libgnome-desktop*/pnp.ids ${datadir}/gnome/*xml" |
| 35 | |
| 36 | RRECOMMENDS_libgnome-desktop3 += "gsettings-desktop-schemas" |