Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
Andrew Geissler | e11f5e2 | 2021-07-20 18:10:59 +0000 | [diff] [blame] | 2 | LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e" |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 3 | DEPENDS = " \ |
| 4 | openssl \ |
| 5 | zlib \ |
| 6 | boost \ |
| 7 | boost-url \ |
| 8 | libpam \ |
| 9 | sdbusplus \ |
| 10 | gtest \ |
| 11 | nlohmann-json \ |
| 12 | libtinyxml2 \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 13 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \ |
| 14 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 15 | " |
Andrew Geissler | 10d1377 | 2022-12-05 11:10:32 -0600 | [diff] [blame^] | 16 | SRCREV = "ddfc67521c537c372d54bc662c74c6e6b73be1c9" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 17 | PV = "1.0+git${SRCPV}" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 18 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 19 | SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1" |
| 20 | SRC_URI += " \ |
| 21 | file://run-ptest \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 22 | " |
Adriana Kobylak | 7e0ff54f | 2018-12-13 11:01:05 -0600 | [diff] [blame] | 23 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket" |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 26 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 27 | inherit systemd |
| 28 | inherit useradd |
| 29 | inherit pkgconfig meson ptest |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 30 | |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 31 | EXTRA_OEMESON = " \ |
| 32 | --buildtype=minsize \ |
| 33 | -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 34 | " |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 35 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 36 | do_install_ptest() { |
| 37 | install -d ${D}${PTEST_PATH}/test |
| 38 | cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/ |
| 39 | } |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 40 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 41 | RDEPENDS:${PN} += " \ |
| 42 | jsnbd \ |
Patrick Williams | 0450a02 | 2022-10-07 21:23:47 -0500 | [diff] [blame] | 43 | phosphor-objmgr \ |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 44 | " |
| 45 | |
| 46 | FILES:${PN} += "${datadir}/** " |
| 47 | |
| 48 | USERADD_PACKAGES = "${PN}" |
| 49 | # add a user called httpd for the server to assume |
| 50 | USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb" |
| 51 | |
| 52 | GROUPADD_PARAM:${PN} = "web; redfish" |
Manojkiran Eda | f1f2e24 | 2020-09-02 21:48:12 +0530 | [diff] [blame] | 53 | FULL_OPTIMIZATION = "-Os " |