Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | sHOMEPAGEsss = "https://pypi.python.org/pypi/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452" |
| 6 | |
| 7 | SRCNAME = "pip" |
| 8 | DEPENDS += "python3 python3-setuptools-native" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ |
| 12 | " |
| 13 | SRC_URI[md5sum] = "5601c4323464add1482291634142894d" |
| 14 | SRC_URI[sha256sum] = "90112b296152f270cb8dddcd19b7b87488d9e002e8cf622e14c4da9c2f6319b1" |
| 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip" |
| 17 | |
| 18 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 19 | |
| 20 | inherit distutils3 |
| 21 | |
| 22 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" |
| 23 | |
| 24 | do_install_prepend() { |
| 25 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages |
| 26 | } |
| 27 | |
| 28 | # Use setuptools site.py instead, avoid shared state issue |
| 29 | do_install_append() { |
| 30 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py |
| 31 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc |
| 32 | |
| 33 | # Install as pip3 and leave pip2 as default |
| 34 | rm ${D}/${bindir}/pip |
| 35 | |
| 36 | # Installed eggs need to be passed directly to the interpreter via a pth file |
| 37 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth |
| 38 | } |
| 39 | |
| 40 | RDEPENDS_${PN} = "\ |
| 41 | python3-compile \ |
| 42 | python3-io \ |
| 43 | python3-json \ |
| 44 | python3-netserver \ |
| 45 | python3-setuptools \ |
| 46 | python3-unixadmin \ |
| 47 | python3-xmlrpc \ |
| 48 | " |