Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
| 3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | # needs to add acl and attr |
| 7 | DEPENDS = "popt" |
| 8 | |
| 9 | SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \ |
| 10 | file://rsync-2.6.9-fname-obo.patch \ |
| 11 | file://rsyncd.conf" |
| 12 | |
| 13 | SRC_URI[md5sum] = "996d8d8831dbca17910094e56dcb5942" |
| 14 | SRC_URI[sha256sum] = "ca437301becd890e73300bc69a39189ff1564baa761948ff149b3dd7bde633f9" |
| 15 | |
| 16 | inherit autotools |
| 17 | |
| 18 | do_install_append() { |
| 19 | install -d ${D}${sysconfdir} |
| 20 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 21 | } |
| 22 | |
| 23 | EXTRA_OEMAKE='STRIP=""' |
| 24 | |
| 25 | LICENSE = "GPLv2+" |
| 26 | LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c" |
| 27 | |
| 28 | PR = "r4" |