Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require rsync.inc |
| 2 | |
| 3 | SRC_URI += "file://makefile-no-rebuild.patch" |
| 4 | |
| 5 | SRC_URI[md5sum] = "0f758d7e000c0f7f7d3792610fad70cb" |
| 6 | SRC_URI[sha256sum] = "ecfa62a7fa3c4c18b9eccd8c16eaddee4bd308a76ea50b5c02a5840f09c0a1c2" |
| 7 | |
| 8 | PACKAGECONFIG ??= "acl attr" |
| 9 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 10 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
| 11 | |
| 12 | # By default, if crosscompiling, rsync disables a number of |
| 13 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 14 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 15 | |
| 16 | # rsync 3.0 uses configure.sh instead of configure, and |
| 17 | # makefile checks the existence of configure.sh |
| 18 | do_configure_prepend () { |
| 19 | rm -f ${S}/configure ${S}/configure.sh |
| 20 | } |
| 21 | |
| 22 | do_configure_append () { |
| 23 | cp -f ${S}/configure ${S}/configure.sh |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native" |