Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU grep utility" |
| 2 | HOMEPAGE = "http://savannah.gnu.org/projects/grep/" |
| 3 | BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv3" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee" |
| 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \ |
| 9 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "f46aa9d0d2577b9212a104348a286787" |
| 13 | SRC_URI[sha256sum] = "54fc478ee1ce17780109820ef30730c9e18715a949f7d5c6afc673adb2a56ecf" |
| 14 | |
| 15 | inherit autotools gettext texinfo |
| 16 | |
| 17 | EXTRA_OECONF = "--disable-perl-regexp" |
| 18 | |
| 19 | do_configure_prepend () { |
| 20 | rm -f ${S}/m4/init.m4 |
| 21 | } |
| 22 | |
| 23 | do_install () { |
| 24 | autotools_do_install |
| 25 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 26 | install -d ${D}${base_bindir} |
| 27 | mv ${D}${bindir}/grep ${D}${base_bindir}/grep |
| 28 | mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep |
| 29 | mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep |
| 30 | rmdir ${D}${bindir}/ |
| 31 | fi |
| 32 | } |
| 33 | |
| 34 | inherit update-alternatives |
| 35 | |
| 36 | ALTERNATIVE_PRIORITY = "100" |
| 37 | |
| 38 | ALTERNATIVE_${PN} = "grep egrep fgrep" |
| 39 | ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" |
| 40 | ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" |
| 41 | ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" |
| 42 | |
| 43 | export CONFIG_SHELL="/bin/sh" |