Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Midnight Commander is an ncurses based file manager" |
| 2 | HOMEPAGE = "http://www.midnight-commander.org/" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 5 | SECTION = "console/utils" |
| 6 | DEPENDS = "ncurses glib-2.0" |
| 7 | RDEPENDS_${PN} = "ncurses-terminfo" |
| 8 | |
| 9 | PR = "r3" |
| 10 | |
| 11 | SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \ |
| 12 | file://mc-CTRL.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "bdae966244496cd4f6d282d80c9cf3c6" |
| 16 | SRC_URI[sha256sum] = "a68338862bb30017eb65ed569a58e80ab66ae8cef11c886440c9e9f4d1efc6ab" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba" |
| 21 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | do_install_append () { |
| 23 | sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/* |
| 24 | sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/* |
| 25 | } |
| 26 | |
| 27 | PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish" |
| 28 | |
| 29 | SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts" |
| 30 | FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \ |
| 31 | ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \ |
| 32 | ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \ |
| 33 | ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \ |
| 34 | ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \ |
| 35 | ${libexecdir}/mc/extfs.d/uzip" |
| 36 | RDEPENDS_${BPN}-helpers-perl = "perl" |
| 37 | |
| 38 | SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts" |
| 39 | FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541" |
| 40 | RDEPENDS_${BPN}-helpers-python = "python" |
| 41 | |
| 42 | SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts" |
| 43 | FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*" |
| 44 | |
| 45 | SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts" |
| 46 | FILES_${BPN}-fish = "${libexecdir}/mc/fish" |
| 47 | |