Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Displays the full path of shell commands" |
| 2 | DESCRIPTION = "Which is a utility that prints out the full path of the \ |
| 3 | executables that bash(1) would execute when the passed \ |
| 4 | program names would have been entered on the shell prompt. \ |
| 5 | It does this by using the exact same algorithm as bash." |
| 6 | SECTION = "libs" |
| 7 | HOMEPAGE = "http://carlo17.home.xs4all.nl/which/" |
| 8 | |
| 9 | LICENSE = "GPLv2+" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 11 | |
| 12 | PR = "r2" |
| 13 | |
| 14 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/which/which-2.18.tar.gz/42d51938e48b91f6e19fabf216f5c3e9/which-${PV}.tar.gz \ |
| 15 | file://fix_name_conflict_group_member.patch \ |
| 16 | file://automake-foreign.patch \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "42d51938e48b91f6e19fabf216f5c3e9" |
| 20 | SRC_URI[sha256sum] = "9445cd7e02ec0c26a44fd56098464ded064ba5d93dd2e15ec12410ba56b2e544" |
| 21 | |
| 22 | DEPENDS = "cwautomacros-native" |
| 23 | |
| 24 | inherit autotools texinfo update-alternatives |
| 25 | |
| 26 | do_configure_prepend() { |
| 27 | OLD="@ACLOCAL_CWFLAGS@" |
| 28 | NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4" |
| 29 | sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}` |
| 30 | } |
| 31 | |
| 32 | ALTERNATIVE_${PN} = "which" |
| 33 | ALTERNATIVE_PRIORITY = "100" |
| 34 | |