Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit Control" |
| 3 | DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \ |
| 4 | to extract program execution details from the Linux operating system \ |
| 5 | and interpret them." |
| 6 | |
| 7 | LICENSE = "GPLv2 & LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \ |
| 9 | file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 10 | file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca" |
| 11 | |
| 12 | DEPENDS = "liburcu popt libxml2" |
| 13 | RDEPENDS_${PN} = "libgcc" |
| 14 | RDEPENDS_${PN}-ptest += "make perl bash" |
| 15 | |
| 16 | SRCREV = "a90f2c1e10b759782653a81815625e9d1bbb75ca" |
| 17 | PV = "2.7.1+git${SRCPV}" |
| 18 | |
| 19 | PYTHON_OPTION = "am_cv_python_pyexecdir='${libdir}/python${PYTHON_BASEVERSION}/site-packages' \ |
| 20 | am_cv_python_pythondir='${libdir}/python${PYTHON_BASEVERSION}/site-packages' \ |
| 21 | PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}' \ |
| 22 | " |
| 23 | PACKAGECONFIG ??= "lttng-ust" |
| 24 | PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python swig-native" |
| 25 | PACKAGECONFIG[lttng-ust] = "--enable-lttng-ust, --disable-lttng-ust, lttng-ust" |
| 26 | PACKAGECONFIG[kmod] = "--enable-kmod, --disable-kmod, kmod" |
| 27 | PACKAGECONFIG_remove_libc-musl = "lttng-ust" |
| 28 | |
| 29 | SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.7 \ |
| 30 | file://Revert-Build-look-for-python-3.0-when-building-pytho.patch \ |
| 31 | file://stop-using-SIGUNUSED.patch \ |
| 32 | file://runtest-2.4.0.patch \ |
| 33 | file://run-ptest" |
| 34 | |
| 35 | S = "${WORKDIR}/git" |
| 36 | |
| 37 | inherit autotools-brokensep ptest pkgconfig useradd |
| 38 | |
| 39 | USERADD_PACKAGES = "${PN}" |
| 40 | GROUPADD_PARAM_${PN} = "tracing" |
| 41 | |
| 42 | FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \ |
| 43 | ${libdir}/python${PYTHON_BASEVERSION}/site-packages/*" |
| 44 | FILES_${PN}-staticdev += "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.a" |
| 45 | FILES_${PN}-dev += "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.la" |
| 46 | |
| 47 | # Since files are installed into ${libdir}/lttng/libexec we match |
| 48 | # the libexec insane test so skip it. |
| 49 | # Python module needs to keep _lttng.so |
| 50 | INSANE_SKIP_${PN} = "libexec dev-so" |
| 51 | INSANE_SKIP_${PN}-dbg = "libexec" |
| 52 | |
| 53 | do_configure_prepend () { |
| 54 | # Delete a shipped m4 file that overrides our patched one |
| 55 | rm -f ${S}/config/libxml.m4 |
| 56 | } |
| 57 | |
| 58 | do_install_ptest () { |
| 59 | chmod +x ${D}${PTEST_PATH}/tests/utils/utils.sh |
| 60 | for i in `find ${D}${PTEST_PATH} -perm /u+x -type f`; do |
| 61 | sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:g" \ |
| 62 | -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \ |
| 63 | -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \ |
| 64 | -e "s:\$TESTDIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:g" \ |
| 65 | -e "s:\$DIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:g" \ |
| 66 | -e "s:\$TESTDIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \ |
| 67 | -e "s:\$DIR/../src/bin/lttng-sessiond/lttng-sessiond:\$SESSIOND_BIN:g" \ |
| 68 | -e "s:\$DIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \ |
| 69 | -e "s:\$DIR/../bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \ |
| 70 | -i $i |
| 71 | done |
| 72 | |
| 73 | # Update libdir references in copied .la files |
| 74 | for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do |
| 75 | sed -i -e 's#${S}/tests/#${STAGING_DIR}${PTEST_PATH}#g' $i |
| 76 | done |
| 77 | |
| 78 | sed -e "s:src/bin:bin:g" -e "s:lt-::g" \ |
| 79 | -i ${D}${PTEST_PATH}/tests/utils/utils.sh |
| 80 | sed -e "s:ini_config:\.libs\/ini_config:" \ |
| 81 | -i ${D}${PTEST_PATH}/tests/unit/ini_config/test_ini_config |
| 82 | } |