Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Binary used to test smack tcp sockets" |
| 2 | DESCRIPTION = "Server and client binaries used to test smack attributes on TCP sockets" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRC_URI = "file://tcp_server.c \ |
| 7 | file://tcp_client.c \ |
| 8 | file://test_smack_tcp_sockets.sh \ |
| 9 | " |
| 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | |
| 13 | do_compile() { |
| 14 | ${CC} tcp_client.c ${LDFLAGS} -o tcp_client |
| 15 | ${CC} tcp_server.c ${LDFLAGS} -o tcp_server |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${bindir} |
| 20 | install -d ${D}${sbindir} |
| 21 | install -m 0755 tcp_server ${D}${bindir} |
| 22 | install -m 0755 tcp_client ${D}${bindir} |
| 23 | install -m 0755 test_smack_tcp_sockets.sh ${D}${sbindir} |
| 24 | } |